X-plane11 blurred


#1

I’m using the Pimax 4K to play X-Plane11, which uses Steam VR, but the display is blurred.
The Pimax logo is sharp when the Pimax is switched on and the Steam VR room is also sharp when setting up the location HMD but the X-Plane view is not sharp.
Can anyone offer any help or this just a limitation of VR currently?

Thanks
Dave


#2

Can I ask what the ipd setting you set in piplay is.

Also what are your system specs and what version of piplay are you using?

Also do you wear glasses or have 50/50 vision? With the 4k assuming you have the right ipd and good vision the clarity should be pretty good apart from the edges of the lens. Some people (me included) who wear glasses have some issues with centre clarity and clear around the edges… Changing the ipd can help, but can leave you feeling cross eyed after a while.

It is well known tho in the pimax 4k that the ipd is not correct for westerners heads… I. E. My real ipd is 63.5 but in the pimax I have to set it around 58 to get clarity in game

Eno


#3

Thanks or the reply Eno.
I’m running the latest version of Piplay and the IPD setting is 62 which is my real IPD and I do wear glasses, varifocals.
I am aware that the Pimax 4K is developed with Chinese eyesight in mind, a short-sighted decision if you’ll pardon the pun.
I have played around with the IPD setting and TBH I haven’t seen any difference in either the game, the Pimax IPD setting screen or the Steam “room” view unless I go to extreme IPD settings.
What I don’t understand is why the Pimax logo and Steam “room” are sharp but X-Plane isn’t. Is the logo and room at a different resolution to the game?
Also I doubt system specs would affect how sharp a game image is but do understand that they would affect frame rates.

Dave


#4

Posting your system specs helps as other users may have similar system; which can help with debugging.

I usually search game title in google with vr & readup if users on vive or oculus are experiencing similar issues.

Game settings can help as well.


#5

Hi Dave, thanks for the info. I find that you can’t use your real ipd in the 4k, also if you have high end PC specs you need to use the piplay render slider to set the render quality to help with smooth visuals. Since version 2.x versions of piplay you no longer need to set steamvrs render as piplay does not use steams compositor.

But I still suspect that it’s the ipd value that is causing your issue. Try settings like 58, 56 etc

Eno


#6

Here are some link that maybe of interest.

X-Plane Forum


#7

System specs
i5-2500K @4.6gHz 15GB RAM GTX1060 6GB

Basically what i am trying to understand is, is it normal for the Pimax logo and IPD setting screen and the Steam VR room to be clear and sharp but the game (any game) to be less sharp.


#8

Hi Eno,

I have Piplay render set to 2x and have tried various in-game graphic settings (ignoring FPS impact) but still distant views are blurred so I suspect it is just the limitation of current VR.
Steam VR automatically starts when I launch X-plane but ISTR that X-plane does have native VR so I need to check that out.
I will have another play with IPD but I have tried various settings even to the extent of seeing double images in game! Can you see a difference in the Pimax IPD setting screen when you change from your real IPD to the setting that works for you Eno?
I may try a cheap pair of standard reading glasses which will eliminate any effect caused by my varifolcals.

Dave


#9

I don’t have the Piplay setting anywhere near 2.0, only 1.0 usually, with steam on 1.2, and distant views are not too blurry. Of course it is subjective and relative to your expectations but with a good IPD setting you can get nice distant views in my experience.

I am sure it does depend on the game though. Some games have their own SS/resolution settings that can affect things greatly. I suggest trying different games to see. I had an awful blur problem in The Vanishing of Ethan Carter. I realised that the game doesn’t use the Piplay SS, so by raising only steam SS the quality improved greatly. Try multiple games and set Piplay to 1.0, steam to 1.5 or so.

Another thing that may possibly affect clarity is the drivers. Nvidia’s latest drivers aren’t very good for vr performance, I went back to 388.59 and all is good.


#10

Happy to say problem solved; it was a plugin in X-Plane that was causing the problem.

Dave


#11

Awesome. Dave if you could maybe share your xplane settings & which plugin caused the issue as this may help others. :beers::sunglasses::+1::sparkles:


#12

The “Flywithlua” plugin was causing the problem.
I’m currently running low graphic settings from my earlier attempts to fix the problem so I will have another play with them to see if I can get better IQ while still maintaining reasonable frame rates. I’ll report back.

Dave