X-Plane11 with 5k+

suggestions

#21

Maybe I was too quick to judge as I only had a brief flight in a light aircraft (I can’t even remember which). It didn’t seem to respond in any way to real airflow around it. It just flew in the direction it was pointed.
Given I knew a lot of systems were yet to be implemented and the world was still static I thought this needs to wait…and wait a long time.
As said it wasn’t a fair go on my part. One aircraft and a brief flight with a few touch and goes. And I can’t help but compare with x-plane 11 because that’s my current civilian aircraft sim and that in itself is a bit unfair given FS2 is new.
I bought it not believing I would be wowed by it but believing I want good aircraft sims and contributing to development is how I can help with that. I bought it hoping it will wow me down the track but developers need buyers before then.


#22

I have the 5k plus with i7-8700k at 5ghz and 1080ti (previous tests with 2080 ti with the rift and xp11 showed no real change, but maybe the 2080 helps with pimax?)…

near london city with TE south, i’m only seeing about 20-22 fps with 3jfps maxed out and 1.0 Pixel tool, fov normal and SS at 100%. I also dont see a huge difference in clarity in the cockpit over rift, especially with the gps units.

I thought going below 90% on SS lead to quality drops. I see you are doing 1.25/ss 60%, maybe worth a try i dont know.

Or worst case I might try lowering fov (for now until vulkan etc).

For easier fps areas i get maybe 37-45 fps (i’m using roughly textures on high, visual hdr, 2ssa, medium or high objects), lowering these doesnt help much… even at this fps i still see ground blurring when you tilt the wings.


#23

Hi,
Thank you for the update!

I have been playing with my 5k+ with an i7 8700k @4.7 ghz and a 1080ti and found the best I could get was with pitool v. 112 at 1.25, FOV Normal (small FOV did not bring any gains) and ss 60% as well. Flying around LOWS with Digital Design Salzburg Airport, which is a FPS hog, and ortho4xp ZL17 tiles and ASXP with broken clouds.
I get 25 - 35 fps with XP settings as follows:

Visual effects - High (HDR)
Texture Quality - Maximum
AA: 2xSSAA+FXAA

No. of world objects: High (with Medium I get 40+ FPS, so the CPU is definitely my weak spot)
Reflection: Minimal
No shadows and no parked aircraft

All the best,

Werner


#24

Your FPS is not far behind me. I can barely go over 30 with TE south on 2080Ti/9900K. So basically we have to skip TE south for now and wait for the Vulcan update or Aerofly version.


#25

Hi,

Has anyone been able to fly XP11 wih new Pitool version .121?

I could not get Xp11 displayed in my hmd, although it was displayed on my monitor. All I saw was that dark space with the white rings.

Wrote about it in the Pitool 1.0.1.121 Beta test release thread.

Had to reinstall Pitool v.112 to run Xp11 again.


#26

Im not even seeing an update on mine (i’m at 1.0.1.112), if i hit check version its not showing a .121 avail?


#27

I managed to find a backup of my pre-sp1 England South… now the frame rate is back up where it needs to be, so for now ill avoid sp1/wait on vulkan.

I also checked gpuz… with sp1 TE South at high objects, my 1080ti’s 8gb ram was exceeded… roughly 8100MB… so i tried lowering to medium objects… that took care of the ram but the gpu was pegged at 99% most of the time.

When i went back to pre-sp1, i put objects on high again… vram was only at 6200mb and the gpu varied between 75-85%.


#28

You have to manually install the beta or wait for a stable release to be made available via PiTool or the download page.

You can find the link to the beta here:


#29

Is anyone having an issue, maybe in general, with getting a weird narrow bar through the goggle display at times. The solution is to power them off and turn back on.


#30

I should also add that in xp11, i still have issues getting the vive controllers to emit a green beam and control things. It seems you have to manually configure the controller from vr, using the vr mouse to assign everything?


#31

The first time you want to configure VR with Pimax you have to map the “VR mouse” to be able to map your controllers.
This should be done once, and then it should remember configuration for the specific profile.


#32

As far as the vr controllers go, i did figure that part out, though i cant seem to figure out what inputs need mapped to manipulate the menu toggle… i can get vr trigger working without issue though.

Secondary issue I now realize too… xp11 is terribly pixelated/jaggy/shimmery (mine is the standalone xp11, not steam version as a side note). I went back to my rift it was night and day. I swear when i first tested the goggles it was not like this. I’ve played with settings but nothing has fixed this.

I even have HDR + 2ssa turned on, pitool set to 1.0 render and wide fov with all checkboxes turned on (i’ve tried turning off smoothing etc).

Im thinking steamvr might be botched, but i even uninstalled/reinstalled steamvr to no avail (and xp11 app setting in steam vr is at 100%).


#33

That is strange, I do not have XP11 from steam and visuals are OK as far as I can tell. It might not be perfect but I don’t remember seeing the shimmering you and sweviver refer, maybe I just don’t know what visual artifact to look for.
Maybe if you can start x-plane not from steam it will work better for you. I only touch the Pitool, defined SS on 1.5 or 1.75 and leave or decrease Steam to ~80%.
It runs quite good, and looks OK.
Again, small labels on the G1000 will be very hard to read without leaning, but overall experience, for me, is good.


#34

My xp11 is the standalone, not running from steam, but steamvr of course runs when you go to vr mode. I didnt realize there was someone else with the issue… i guess not completely alone then.

Its pretty night and day. Its like going from full AA smooth edges on buildings to a jaggy mess. I’m not sure what is botched though.

Are you saying you set the render option in pitool to 1.5? I’ve only ever left that at 1 with steamvr set to 100% for the xplane.exe application profile (the other page with the video override checkbox based on gpu, i dont have that checked but if i were to check that off it has the slider at 28%).

If i bring up steam overlay inside the goggles, the application supersampling seems set automatically to 0.3 and only the first check box is checked (despite in the 2d gui for steam the app process showing 100%)… i’ve tried sliding it to 1.0 and it doesnt seem to help. Not sure what the “0.3” is or where it comes from.

edit: side note… changing the fov to small vs normal or wide, i see no change in fps for some reason.


#35

What I know from what I read in this forum and heard from swiviver, is that when you are in Paraller Projection mode, then steam SS is less relevant and your main SS should be from PiTool.
This seem to be on par of what I see, more or less. Swiviver suggested not to move SS lower than 80% in steam, so I just go with that, and in PiTool I try to crank SS as high as possible for better fidelity.

In X-Plane settings I move slider to FXAA and MSAAx2, I think MSAAx4 is much better but to demanding on my GPU. I do admit that I care less on the buildings looks, more on the cockpit readability, since once I’m airborne and above 2000ft the further graphics look washed out a little, or out of focus in away (small ones like trees).

I guess that it will take few years more until we will have an HMD that can provide such fidelity in flight sims.


#36

Is x plane working with the new pitool beta .121 yet or are you using an older pitool?


#37

Older. I use the 109.


#38

Hi,
Pitool v.121 does not work with Xp11.

Went back to Pitool v.112, which works fine.


#39

I really like the new pitool for Elite dangerous and Skyrim so I’ve decided to have an x plane hiatus until they get it working.


#40

What render setting are you using in pitool?

I want to say maybe my jaggies are from ssa2… i have hdr on so ssa2 in effect… when i first did the test with the goggles i tried hdr off and aax4… maybe ssa2 is bad and causing the issue strangely.

Side note for everyone: pitool beta the .111 version… i thought i read that you can avoid using steamvr if you are using this beta, that on the games list in pitool it would NOT say “launch steamvr” under the title… but this doesnt seem to be the case.

Has anyone found a way to run xp11 WITHOUT steamvr and only the pitool beta and if so how is it working for you (since i cant seem to do it)?