You guys want to play steam games with your PIMAX? Just take a look here!


#1

1. Make sure that you’ve got the latest version of Pimax firmware and Piplay.

SteamSetup dowload link

2. Install steam then find steamVR.

and install it!

3.Make sure Piplay has been hooked up with pimax mode, then click on the “VR” icon on the upper right of the steam interface to open steamVR.

4.If this is the first time you run SteamVR, you must run the room setup.

AND NOW, you’re ready to play steam games with your Pimax 4K!!

Tips: Have you tried playing Warthunder in VR mode, its pretty cooooooooooool!!!.
:yum:


Essence posts summary
[NEW TO PLAY SUMMARY] Just take your 10 mins to be good at playing Pimax 4K VR
#2

In fact, I’m enjoying some games in SteamVR:laughing:


#3

I would prefer to get an answer to the question why, after updating to the latest piplay after going to the settings app on direct mode glasses do not want to connect?
I can not play on steam because they are not available


#4

My headset will not load in Direct Mode, so it is impossible to connect to Steam VR. It doesnt work at all.


#5

What is your video card? You can use the Pimax mode in the newest Pimax version if you are the using the 10 sense video card.


#6

I have a GTX970 and also a Radeon R9 295x2. Neither of them allow for any mode other than Extend. I have tried on two different windows installations. Is there any thing else i need to install or configure other than piplay and steam? I installed oculus and that seemed to make the PIMAX behave differently. It would not show up as a display and I could actually get steam to connect, but nothing would display in the headset and PIPLAY would say “where is my pimax?” so it wasnt detecting it. I uninstalled Oculus and it goes back to only connecting in extend mode.


#7

my card GTX950 and intel i5. In the old version piplay Steam vr work although it was at the beginning of the problems. Now the steam does not work and after switching to the direct mode in application piplay can not connect with glasses, nothing works as it should. Games downloaded from pip lay in extend mode have problems starting and they crash, I can say direct mode does not exist in piplay, so it can not be, with such software will not go away


#8

i had the same problem i have uninstalled the new pimax installed old one and got message from it that i need older nvidia driver in order to work did that and now its working but to switch between modes i am using the app A tool to switch the modes between pimax mode & compatible mode

i think if i install back the new piplay it would probably work because trouble was new nvidia driver but i am not gonna risk it :smiley:

yeah and i also reinstalled the steam but i dont know if this is necessary in order to fix the new firmware into direct mode problem (also reinstalled java).


#9

The old version of piplay download link no longer works. Also that site you linked to is in chinese and I cannot figure out how to download…


#10

Just try to install older nvidia driver it helped me i just got message from the piplay that i need o install driver i installed version 362 now its working with new piplay and i also reinstalled steam idk if this had to do something with it but now its working http://www.nvidia.com/download/driverResults.aspx/99196/en-us


#11

I tried nvidia 362 on the gtx 970 and it still did not have direct mode. I might need to start from scratch again… how frustrating


#12

yeah i uninstalled everything and installed again and its working now hard to say what solved the issue


#13

OK i got it to work. I uninstalled everything and used Radeon 15.12 Crimson drivers. It seems to be working fine now. (still though, occasional issues and have to restart)


#14

Here is my fix guys on how to get Direct Mode To Work Easy Fix:


#15

Hi i have a question. After a while I managed to make steam vr recognize my headset but when I finish calibrating and making the tutorial, all that shows is a grey room. I googled it and it says that I need to press the “system button” to open the dashboard (menu) on that grey room.
But pimax doesnt have system button, does it? how do you open it?
Thanks!


#16

Just load up a SteamVR app directly while you’re in the grey room if all else fails.


#17

If it shows you a grey room means you’re ready, you could now run a VR game on steam. :yum:


#18

SteamVR need a controller to be used, in the Xbox controllers, the “System Button” is the Xbox Button :wink:


#19

Thank you all it worked. :slight_smile:


#20