You guys want to play steam games with your PIMAX? Just take a look here!


Here is my fix guys on how to get Direct Mode To Work Easy Fix:


Hi i have a question. After a while I managed to make steam vr recognize my headset but when I finish calibrating and making the tutorial, all that shows is a grey room. I googled it and it says that I need to press the “system button” to open the dashboard (menu) on that grey room.
But pimax doesnt have system button, does it? how do you open it?


Just load up a SteamVR app directly while you’re in the grey room if all else fails.


If it shows you a grey room means you’re ready, you could now run a VR game on steam. :yum:


SteamVR need a controller to be used, in the Xbox controllers, the “System Button” is the Xbox Button :wink:


Thank you all it worked. :slight_smile:



i have the same problem : grey room and apps are loading only on my desktop monitor. What helped you because i dont understand?


Hi, that is the Steam problem. The latest Steam version has this problem, please try to use the latest Piplay version, and use the Pimax mode to solve this problem. Thank u so much!


Finally got headset to be recognised and calibrated in steamVR, but only ever get grey room. Games load on my monitor, steamVR reports gream “Ready” with “(unresponsive)” in red underneath. Headset icon lights up in green and recognises head tracking, but game will not display in the headset. What is going on?


When connected to Steam VR the headset light must be blue.
You are probably not in pimax mode.

Here is my method in order to connect with success :
_ first the headset must be in pimax mode
_ unplug your Pimax (usb and hdmi)
_ start your computer
_ plug the pimax (usb and hdmi) and wait the noise of the driver which take care of the pimax
_ start Steam
_ right click on steam icon in the tray bar and start Steam VR
_ wait until all is green without the red message, the led of the heaset should become blue
_ if Steam VR don’t recognize correctly the pimax, close the steam vr window (not Steam) and start it again as many times you need until it works.
_ that’s it, now start your game in HTC VIVE- Steam VR mode if steam ask you.(not oculus)

If you get a piprocess issue during this process, you can start all again.


I’ve tried this more times than I can count. Headset will not play anything in SteamVR. Also, when playing a non Steam game in extended mode, left and right screens are well out of sync, no adjustment to IPD will line the screens up. It doesn’t work either, let alone no head tracking.

These headsets are a long way off being ready for normal consumer use. I shouldn’t have to be a technician just to get it to work, and it still doesn’t work anyway. Shame, as it has such high hopes of being a great headset.


You was in pimax mode?

If the piservice has failed it will not work.


In Pimax mode, service was running. Still don’t work


You can contact the to ask for help.


Tried that, no one answers my call


What is your ID and can you send a message?



I’m on piplay 1.2.75 and firmware and i have steam VR installed, a blue light on the headset, the pimax logo inside the headset and piplay running, but piplay will insist that Steam VR is not installed… :confused:


Necro thread :slight_smile:

Getting back to messing about with the Pimax, With PiPlay 1.2.57 (International) and the OC Plugin. My experience is that the OC Plugin is great at getting PiPlay to find the headset. I launch Piplay, then the OC Plugin. Click reset, and seconds later the GUI registers the headset. Magic!

After that getting into the SteamVR demo room is as easy as clicking “SteamVR” in the GUI. Give it 30 seconds and it loads up and head tracking works, as does audio. The problem I have is that for ages it said to press Y on my xbox controller. But it never worked, turns out that the “play and change kit” is charge only. You need the MSFT Wireless adapter for PC to get the controller to show up as an actual controller.

I know it’s working, as the headset and the controller light up green in the SteamVR status notification window. That and pressing The green A button gives an audio tone. It has also Corrupted/written over the text box that says to press Y, with text that says that when I install games they will appear there. Having watched somebody launch SkyrimVR it appears that VR games will appear in the center column.

Then I got bored of messing about with that and bought VorpX, which works with Skyrim and the special edition, without needing to use an odd controller, or anything else. It is a modded game, (SE) It will even work to an extent with ENB, though it says it won’t.

I do have issues with the display, though hopefully that will be fixed by downloading a profile as I hacked about with it on my own to some effect, but in a very unstructured manner. Though it does work as advertised. I’m using xpadder as a controller so I had full mouse and keyboard support via an old Xbox Controller S which has more addressable buttons in a usable manner than anything else I’ve ever found in years of looking.

The 3D effect was limited IMO, and it didn’t help that I spawned outside in a fort courtyard in the dark in a snowstorm. Though the next morning my heart sang a little when I emerged in a blue sky over white snow. It looked right. Though I guess it needs to be calibrated. Luckily I have the example of SkyrimVR as to how to do this.